
<!doctype html>

<html class="no-js" lang="en-US">

<head>
    <meta charset="utf-8">

    <meta http-equiv="X-UA-Compatible" content="IE=edge">

    <meta name="viewport" content="width=device-width, initial-scale=1.0">

    <title>The Obi-Wan finale was pretty much perfect | Boing Boing</title>

	        <meta itemprop="name"
              content="The Obi-Wan finale was pretty much perfect">
        <meta itemprop="headline"
              content="The Obi-Wan finale was pretty much perfect">
        <meta itemprop="author" content="">
        <meta itemprop="description" content="The Obi-Wan finale was pretty much perfect"/>
        <link itemprop="url" href="https://boingboing.net/2022/06/22/the-obi-wan-finale-was-pretty-much-perfect.html">
        <link itemprop="thumbnailUrl" href="https://boingboing.net/wp-content/uploads/2022/05/obiwan-img.jpeg">
	
	
    <link rel="pingback" href="https://boingboing.net/xmlrpc.php">

	<meta name='robots' content='max-image-preview:large' />
<!-- Jetpack Site Verification Tags -->
<meta name="google-site-verification" content="2Z2CdDZoCt3kedjrHnPrbA3HjYnoXwwgy2pjFo552ws" />
<meta name="msvalidate.01" content="24ECEF65525D0D014895DB1255B1A9D0" />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel='dns-prefetch' href='//i0.wp.com' />
<link rel='dns-prefetch' href='//v0.wordpress.com' />
<link rel='dns-prefetch' href='//c0.wp.com' />
<link rel="alternate" type="application/rss+xml" title="Boing Boing &raquo; Feed" href="https://boingboing.net/feed" />
<link rel="alternate" type="application/rss+xml" title="Boing Boing &raquo; Comments Feed" href="https://boingboing.net/comments/feed" />
<script type="text/javascript">
window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/14.0.0\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/14.0.0\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/boingboing.net\/wp-includes\/js\/wp-emoji-release.min.js?ver=6.0"}};
/*! This file is auto-generated */
!function(e,a,t){var n,r,o,i=a.createElement("canvas"),p=i.getContext&&i.getContext("2d");function s(e,t){var a=String.fromCharCode,e=(p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,e),0,0),i.toDataURL());return p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,t),0,0),e===i.toDataURL()}function c(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(o=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},r=0;r<o.length;r++)t.supports[o[r]]=function(e){if(!p||!p.fillText)return!1;switch(p.textBaseline="top",p.font="600 32px Arial",e){case"flag":return s([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])?!1:!s([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!s([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]);case"emoji":return!s([129777,127995,8205,129778,127999],[129777,127995,8203,129778,127999])}return!1}(o[r]),t.supports.everything=t.supports.everything&&t.supports[o[r]],"flag"!==o[r]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[o[r]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(e=t.source||{}).concatemoji?c(e.concatemoji):e.wpemoji&&e.twemoji&&(c(e.twemoji),c(e.wpemoji)))}(window,document,window._wpemojiSettings);
</script>
<!-- boingboing.net is managing ads with Advanced Ads 1.34.0 – https://wpadvancedads.com/ --><script id="boing-ready">
			window.advanced_ads_ready=function(e,a){a=a||"complete";var d=function(e){return"interactive"===a?"loading"!==e:"complete"===e};d(document.readyState)?e():document.addEventListener("readystatechange",(function(a){d(a.target.readyState)&&e()}),{once:"interactive"===a})},window.advanced_ads_ready_queue=window.advanced_ads_ready_queue||[];		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 0.07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='wp-block-library-css'  href='https://c0.wp.com/c/6.0/wp-includes/css/dist/block-library/style.min.css' type='text/css' media='all' />
<style id='wp-block-library-inline-css' type='text/css'>
.has-text-align-justify{text-align:justify;}
</style>
<link rel='stylesheet' id='mediaelement-css'  href='https://c0.wp.com/c/6.0/wp-includes/js/mediaelement/mediaelementplayer-legacy.min.css' type='text/css' media='all' />
<link rel='stylesheet' id='wp-mediaelement-css'  href='https://c0.wp.com/c/6.0/wp-includes/js/mediaelement/wp-mediaelement.min.css' type='text/css' media='all' />
<style id='global-styles-inline-css' type='text/css'>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</style>
<link rel='stylesheet' id='qc-choice-css'  href='https://boingboing.net/wp-content/plugins/quantcast-choice/public/css/style.min.css?ver=2.0.4' type='text/css' media='all' />
<link rel='stylesheet' id='site-css-css'  href='https://boingboing.net/wp-content/themes/boing/assets/styles/style.min.css?ver=1635211842' type='text/css' media='all' />
<link rel='stylesheet' id='jetpack_css-css'  href='https://c0.wp.com/p/jetpack/11.0/css/jetpack.css' type='text/css' media='all' />
<script type='text/javascript' id='qc-choice-js-extra'>
/* <![CDATA[ */
var choice_cmp_config = {"utid":"gz35SZjJgwWt-","enabled":"all","ccpa":"auto","datalayer":""};
/* ]]> */
</script>
<script type='text/javascript' async="async" src='https://boingboing.net/wp-content/plugins/quantcast-choice/public/js/script.min.js?ver=2.0.4' id='qc-choice-js'></script>
<script type='text/javascript' src='https://c0.wp.com/c/6.0/wp-includes/js/jquery/jquery.min.js' id='jquery-core-js'></script>
<script type='text/javascript' src='https://c0.wp.com/c/6.0/wp-includes/js/jquery/jquery-migrate.min.js' id='jquery-migrate-js'></script>
<script type='text/javascript' id='advanced-ads-advanced-js-js-extra'>
/* <![CDATA[ */
var advads_options = {"blog_id":"1","privacy":{"custom-cookie-name":"","custom-cookie-value":"","consent-method":"iab_tcf_20","enabled":false,"state":"not_needed"}};
/* ]]> */
</script>
<script type='text/javascript' src='https://boingboing.net/wp-content/plugins/advanced-ads/public/assets/js/advanced.min.js?ver=1.34.0' id='advanced-ads-advanced-js-js'></script>
<link rel="https://api.w.org/" href="https://boingboing.net/wp-json/" /><link rel="alternate" type="application/json" href="https://boingboing.net/wp-json/wp/v2/posts/899228" /><link rel="canonical" href="https://boingboing.net/2022/06/22/the-obi-wan-finale-was-pretty-much-perfect.html" />
<link rel='shortlink' href='https://boingboing.net/?p=899228' />
<link rel="alternate" type="application/json+oembed" href="https://boingboing.net/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fboingboing.net%2F2022%2F06%2F22%2Fthe-obi-wan-finale-was-pretty-much-perfect.html" />
<link rel="alternate" type="text/xml+oembed" href="https://boingboing.net/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fboingboing.net%2F2022%2F06%2F22%2Fthe-obi-wan-finale-was-pretty-much-perfect.html&#038;format=xml" />
<link rel="apple-touch-icon" sizes="180x180" href="/wp-content/uploads/fbrfg/apple-touch-icon.png?v=2.1">
<link rel="icon" type="image/png" sizes="32x32" href="/wp-content/uploads/fbrfg/favicon-32x32.png?v=2.1">
<link rel="icon" type="image/png" sizes="16x16" href="/wp-content/uploads/fbrfg/favicon-16x16.png?v=2.1">
<link rel="manifest" href="/wp-content/uploads/fbrfg/site.webmanifest?v=2.1">
<link rel="mask-icon" href="/wp-content/uploads/fbrfg/safari-pinned-tab.svg?v=2.1" color="#ff0000">
<link rel="shortcut icon" href="/wp-content/uploads/fbrfg/favicon.ico?v=2.1">
<meta name="msapplication-TileColor" content="#b91d47">
<meta name="msapplication-config" content="/wp-content/uploads/fbrfg/browserconfig.xml?v=2.1">
<meta name="theme-color" content="#ffffff"><script type="text/javascript">
		var advadsCfpQueue = [];
		var advadsCfpAd = function( adID ){
			if ( 'undefined' == typeof advadsProCfp ) { advadsCfpQueue.push( adID ) } else { advadsProCfp.addElement( adID ) }
		};
		</script>
		<style>img#wpstats{display:none}</style>
	<meta name="description" content="I was absolutely thrilled at the conclusion of the final episode of Star Wars: Obi-Wan Kenobi. After the massive disappointments of their last mini-series, I was super concerned Kenobi would fall apart, and Disney managed to keep that suspense through Episode 5, right up to the finale where they just nailed it. https://www.youtube.com/watch?v=utFRqsT61-k All the&hellip;" />
<link rel="amphtml" href="https://boingboing.net/2022/06/22/the-obi-wan-finale-was-pretty-much-perfect.html/amp">
<!-- Jetpack Open Graph Tags -->
<meta property="og:type" content="article" />
<meta property="og:title" content="The Obi-Wan finale was pretty much perfect | Boing Boing" />
<meta property="og:url" content="https://boingboing.net/2022/06/22/the-obi-wan-finale-was-pretty-much-perfect.html" />
<meta property="og:description" content="I was absolutely thrilled at the conclusion of the final episode of Star Wars: Obi-Wan Kenobi. After the massive disappointments of their last mini-series, I was super concerned Kenobi would fall a…" />
<meta property="article:published_time" content="2022-06-22T17:09:36+00:00" />
<meta property="article:modified_time" content="2022-06-22T17:09:40+00:00" />
<meta property="og:site_name" content="Boing Boing" />
<meta property="og:image" content="https://i0.wp.com/boingboing.net/wp-content/uploads/2022/05/obiwan-img.jpeg?fit=845%2C500&#038;ssl=1" />
<meta property="og:image:width" content="845" />
<meta property="og:image:height" content="500" />
<meta property="og:image:alt" content="" />
<meta property="og:locale" content="en_US" />
<meta name="twitter:creator" content="@BoingBoing" />
<meta name="twitter:site" content="@BoingBoing" />
<meta name="twitter:text:title" content="The Obi-Wan finale was pretty much perfect" />
<meta name="twitter:image" content="https://i0.wp.com/boingboing.net/wp-content/uploads/2022/05/obiwan-img.jpeg?fit=845%2C500&#038;ssl=1&#038;w=640" />
<meta name="twitter:card" content="summary_large_image" />

<!-- End Jetpack Open Graph Tags -->
<!-- begin AA "Head JS" -->
<!-- Google Tag Manager -->
<script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
'https://www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
})(window,document,'script','dataLayer','GTM-NNJ24Q2');</script>
<!-- End Google Tag Manager -->

<!-- begin Google Analytics -->
<!-- Global site tag (gtag.js) - Google Analytics GA3 -->
<script async src="https://www.googletagmanager.com/gtag/js?id=UA-3839311-1"></script>
<script>
  window.dataLayer = window.dataLayer || [];
  function gtag(){dataLayer.push(arguments);}
  gtag('js', new Date());

  gtag('config', 'UA-3839311-1');
</script>
<!-- Global site tag (gtag.js) - Google Analytics GA4 -->
<script async src="https://www.googletagmanager.com/gtag/js?id=G-X0MTXTYEJ1"></script>
<script>
  window.dataLayer = window.dataLayer || [];
  function gtag(){dataLayer.push(arguments);}
  gtag('js', new Date());

  gtag('config', 'G-X0MTXTYEJ1');
</script>
<!-- End Google Analytics -->

<!-- UnrulyX tag -->
<script>var unruly=window.unruly || {};unruly.native=unruly.native || {};unruly.native.siteId=1021419;</script>
<script src="//video.unrulymedia.com/native/native-loader.js"></script>
<!-- End UnrulyX tag -->

<!-- Facebook Pixel Code -->
<script>!function(f,b,e,v,n,t,s){if(f.fbq)return;n=f.fbq=function(){n.callMethod?n.callMethod.apply(n,arguments):n.queue.push(arguments)};if(!f._fbq)f._fbq=n;n.push=n;n.loaded=!0;n.version='2.0';n.queue=[];t=b.createElement(e);t.async=!0;t.src=v;s=b.getElementsByTagName(e)[0];s.parentNode.insertBefore(t,s)}(window,document,'script','https://connect.facebook.net/en_US/fbevents.js');fbq('init', '1174428159312267');fbq('track', 'PageView');</script>
<noscript><img loading="lazy" height="1" width="1" style="display:none" src="https://www.facebook.com/tr?id=1174428159312267&ev=PageView&noscript=1" /></noscript>
<!-- DO NOT MODIFY -->
<!-- End Facebook Pixel Code -->

<!-- AD CODE -->
<!-- freestar -->
<link rel="stylesheet" href="https://a.pub.network/core/pubfig/cls.css">
<script data-cfasync="false" type="text/javascript">
  var freestar = freestar || {};
  freestar.hitTime = Date.now();
  freestar.queue = freestar.queue || [];
  freestar.config = freestar.config || {};
  // creates a key debug which is used for testing and, or staging
  freestar.debug = window.location.search.indexOf('fsdebug') === -1 ? false : true;
  freestar.config.enabled_slots = [];
  !function(a,b){var c=b.getElementsByTagName("script")[0],d=b.createElement("script"),e="https://a.pub.network/boingboing-net";e+=freestar.debug?"/qa/pubfig.min.js":"/pubfig.min.js",d.async=!0,d.src=e,c.parentNode.insertBefore(d,c)}(window,document);
  freestar.initCallback = function () {
	(freestar.config.enabled_slots.length === 0) ? freestar.initCallbackCalled = false : freestar.newAdSlots(freestar.config.enabled_slots);
  }
</script>
<script src="https://a.pub.network/boingboing-net/pubfig.min.js" async></script>
<!-- AIR.TV -->
<!-- script async='async' data-cfasync='false' src='https://embed.air.tv/v1/twoview_bootstrap.js?organization=hhEg2vg9TPS42CHLfgIziA'></script -->
<!-- END OF AD CODE -->
<!-- End AA "Head JS" --><link rel="icon" href="https://i0.wp.com/boingboing.net/wp-content/uploads/2018/04/apple-touch-icon-1.png?fit=32%2C32&#038;ssl=1" sizes="32x32" />
<link rel="icon" href="https://i0.wp.com/boingboing.net/wp-content/uploads/2018/04/apple-touch-icon-1.png?fit=158%2C158&#038;ssl=1" sizes="192x192" />
<link rel="apple-touch-icon" href="https://i0.wp.com/boingboing.net/wp-content/uploads/2018/04/apple-touch-icon-1.png?fit=158%2C158&#038;ssl=1" />
<meta name="msapplication-TileImage" content="https://i0.wp.com/boingboing.net/wp-content/uploads/2018/04/apple-touch-icon-1.png?fit=158%2C158&#038;ssl=1" />
		<style type="text/css" id="wp-custom-css">
			.sync-iframe {
    display: block
}		</style>
		
<script async src='/cdn-cgi/challenge-platform/h/g/scripts/invisible.js?ts=1655913600'></script></head>

<body class="post-template-default single single-post postid-899228 single-format-standard single-blog aa-prefix-boing-">

<header class="header" role="banner">
	<div class="site-header">
    
    <div class="row">

        <nav class="navbar" role="navigation" aria-label="main navigation">

            <div class="navbar-brand">
								                    <a class="navbar-item" href="https://boingboing.net">
                        <img alt="BoingBoing"
                             src="https://boingboing.net/wp-content/themes/boing/assets/images/logo-boingboing.png"
                             width="117"
                             height="18">
                    </a>
				
                <button role="button"
                        class="navbar-burger burger"
                        aria-label="menu"
                        aria-expanded="false"
                        data-target="bb_navbar">
					MENU                </button>
            </div>

            <div id="bb_navbar" class="navbar-menu">

                <div class="navbar-start">

                    <a href="https://boingboing.net/search" class="navbar-item">
						SEARCH                    </a>

                    <a href="https://store.boingboing.net" class="navbar-item">
						STORE                    </a>

                    <div class="navbar-item bb-menu-toggle">
                        <button
                                class="navbar-burger navbar-item"
                                aria-label="menu"
                                aria-expanded="false"
                                data-target="bb_menu">
							MENU                        </button>
                    </div>

                </div>

                <ul id="bb_menu" class="bb-menu menu-items">
                    <li class="mobile-only">
                        <a href="https://boingboing.net/search" class="navbar-item">
							SEARCH                        </a>
                    </li>
                    <li class="mobile-only">
                        <a href="https://store.boingboing.net" class="navbar-item">
							STORE                        </a>
                    </li>
                    <li>
                        <a href="https://boingboing.net/blog">
							Blog                        </a> : The posts                    </li>
                    <li>
                        <a href="https://bbs.boingboing.net">Forums</a> : Read the                        <a href="https://bbs.boingboing.net/faq">rules</a>
                    </li>
                    <li>
                        <a href="https://store.boingboing.net">Store</a> : Wonderful Products                        <a href="https://bit.ly/boingboingdealssupport">(Contact Support)</a>
                    </li>
                    <li>
                        <a href="https://boingboing.net/about">About Us</a> : Writers and staff                    </li>
                    <li>
                        <a href="https://boingboing.net/contact">Contact Us</a> : Get satisfaction                    </li>
                    <li>
                        <a href="https://ads.boingboing.net">Advertise</a> : Thank you for reading                    </li>
                    <li>
                        <a href="https://boingboing.net/privacy">Privacy Policy</a> : The data you generate                    </li>
                    <li>
                        <a href="https://boingboing.net/tos">TOS</a> : What you agree to                    </li>
                </ul>

            </div>
        </nav>
    </div>
</div>

</header>
    <main role="main">

		
				<div class="container">
	<!-- Horizontal Ad block -->

<div class="boing-leaderboard-below-menu" id="boing-633626818"><div id="leaderboard" style="min-height: 50px;">
	<!-- /5611/boinboing -->
	<!-- Tag ID: boingboing_728x90_970x90_970x250_320x50_ATF -->
	<div class="adslot leaderboard" data-freestar-ad="__320x100 __970x250" id="boingboing_728x90_970x90_970x250_320x50_ATF">
		<script data-cfasync="false" type="text/javascript">
    		freestar.config.enabled_slots.push({ placementName: "boingboing_728x90_970x90_970x250_320x50_ATF", slotId: "boingboing_728x90_970x90_970x250_320x50_ATF" });
		</script>
	</div>
</div></div></div>
<article id="post-899228" class="post-899228 post type-post status-publish format-standard has-post-thumbnail hentry category-post tag-star-wars"         role="article"
         itemscope
         itemtype="http://schema.org/BlogPosting">

    <div class="container">

        <div class="columns tile is-ancestor">

            <div class="tile column is-vertical is-12">

                <header class="article-header">

                    <h1 class="entry-title single-title" itemprop="headline">The Obi-Wan finale was pretty much perfect</h1>

                    <div class="article-meta">

						<a class="byline"
   href="https://boingboing.net/author/jason">
	Jason Weisberger</a>
						<time class="post-date" datetime="2022-06-22T10:09:36-07:00">
    <span class="post-time">
        10:09 am Wed    </span>
    <span class="post-date">
        Jun 22, 2022    </span>
</time>
                    </div>

                </header>

            </div>

        </div>

		
        <div class="columns tile is-ancestor">

            <div class="tile column is-vertical is-8">

				                            <div class="featured-image">
                                <img alt=""
                                     width="620"
                                     src="https://i0.wp.com/boingboing.net/wp-content/uploads/2022/05/obiwan-img.jpeg?fit=1&resize=620%2C4000&ssl=1">
								                            </div>
						
				

                <section class="entry-content" itemprop="text">
					
<p>I was absolutely thrilled at the conclusion of the final episode of <em>Star Wars: Obi-Wan Kenobi. </em>After the massive disappointments of their last mini-series, I was super concerned Kenobi would fall apart, and Disney managed to keep that suspense through Episode 5, right up to the finale where they just nailed it. </p>



<figure class="wp-block-embed is-type-video is-provider-youtube wp-block-embed-youtube wp-embed-aspect-16-9 wp-has-aspect-ratio"><div class="wp-block-embed__wrapper">
<span class="embed-youtube" style="text-align:center; display: block;"><iframe class="youtube-player" width="970" height="546" src="https://www.youtube.com/embed/utFRqsT61-k?version=3&#038;rel=1&#038;showsearch=0&#038;showinfo=1&#038;iv_load_policy=1&#038;fs=1&#038;hl=en-US&#038;autohide=2&#038;wmode=transparent" allowfullscreen="true" style="border:0;" sandbox="allow-scripts allow-same-origin allow-popups allow-presentation"></iframe></span>
</div></figure>



<p>All the storylines came together as perfectly as you could hope. Folks concerned with canon are given room to do their thing; fans who watch for the inconsistencies have a whole disappearing Star Destroyer to discuss; but folks who love fan service just got a giant, wonderful bounty. </p><div class="boing-primis-video-in-article-content" id="boing-1647196525"><div id="boingboingarticleFreeStarVideoAdContainer">
	<div id="freestar-video-parent">
		<div id="freestar-video-child"></div>
	</div>
</div></div>



<p>As we expected, Obi-Wan figures his shit out, is still the guy who cut off Vader's legs and left him to roast, and has a beaming smile. The lightsaber battle was as epic as promised. I loved the moment Obi-Wan changed from his defensive form to go on the attack. </p>



<p>On of the most important things, this series confirmed for us is that Leia was always the most interesting character, and Luke is fine. It seems clear which young Skywalker we ought to see having more adventures. Vivien Lyra Blair, who plays young Leia, did an amazing job. </p>



<p>The only loose ends all point to a second series, which I think will be wonderful.  Obi-Wan and spirit Qui-Gon doing a Bing and Bob kinda thing could be fun. </p><div class="boing-primis-video-in-lower-part-of-article" id="boing-622002999"><div id="boingboingarticleFreeStarVideoAdContainer">
	<div id="freestar-video-parent">
		<div id="freestar-video-child"></div>
	</div>
</div></div>
                </section>

				<div class="share-comments-container">
	    <ul class="share-list">
			<li>
            <a class="twitter"
               href="https://twitter.com/intent/tweet?text=The+Obi-Wan+finale+was+pretty+much+perfect https%3A%2F%2Fboingboing.net%2F2022%2F06%2F22%2Fthe-obi-wan-finale-was-pretty-much-perfect.html&original_referer=https%3A%2F%2Fboingboing.net%2F2022%2F06%2F22%2Fthe-obi-wan-finale-was-pretty-much-perfect.html"
               target="_blank">TWEET</a>
        </li>
	<li><a class="bbs" href="https://bbs.boingboing.net/t/the-obi-wan-finale-was-pretty-much-perfect/223974"> COMMENTS</a></li>    </ul>

	            <ul class="tags-list">
				                    <li><a href="https://boingboing.net/tag/star-wars">star wars</a></li>
				            </ul>
		</div>

				
				<div class="boing-single-post-rev-content" id="boing-249952185"><!-- Revcontent -->
<div id="rc-widget-432dcc" data-rc-widget data-widget-host="habitat" data-endpoint="//trends.revcontent.com" data-widget-id="113901"></div>
<script type="text/javascript" src="https://assets.revcontent.com/master/delivery.js" defer="defer"></script>  
<!-- end Revcontent --></div><section class="next-post-list-container">
    <ul>
		            <li><div class="next-article">
    <header class="article-header">
        <h2 class="entry-title">
            <a href="https://boingboing.net/2022/06/15/things-go-where-they-must-as-obi-wans-foregone-conclusion-looms.html">
				Things go where they must as Obi-Wan's foregone conclusion looms            </a>
        </h2>
    </header>
    <p>
        <a class="article-image" href="https://boingboing.net/2022/06/15/things-go-where-they-must-as-obi-wans-foregone-conclusion-looms.html">
			        <img alt=""
             width="250"
             height="190"
             src="https://i0.wp.com/boingboing.net/wp-content/uploads/2022/05/obiwan-img.jpeg?resize=250%2C190&ssl=1"
             loading="lazy">
	        </a>
		The fifth and penultimate episode of Obi-Wan Kenobi pretty much delivered what everyone knew it had to, with few added surprises. All the story elements people kind of care about but aren't really core to the story got wrapped up because they needed to be mostly wrapped up. Next week we get sort of what&hellip;        <a href="https://boingboing.net/2022/06/15/things-go-where-they-must-as-obi-wans-foregone-conclusion-looms.html" class="read-more-link">READ THE REST</a>
    </p>
</div></li>
		            <li><div class="next-article">
    <header class="article-header">
        <h2 class="entry-title">
            <a href="https://boingboing.net/2022/06/08/the-fourth-episode-of-obi-wan.html">
				The fourth episode of Obi-Wan            </a>
        </h2>
    </header>
    <p>
        <a class="article-image" href="https://boingboing.net/2022/06/08/the-fourth-episode-of-obi-wan.html">
			        <img alt=""
             width="250"
             height="190"
             src="https://i0.wp.com/boingboing.net/wp-content/uploads/2022/05/obiwan-img.jpeg?resize=250%2C190&ssl=1"
             loading="lazy">
	        </a>
		I woke up early, because like Obi-Wan I'm not staying up late in my 50s, but I urgently wanted to watch this show. The episode gives you some of the "Obi is coming back" that you are looking for, while mostly just carrying the story forward to its obvious and anticipated conclusion. Obi will find&hellip;        <a href="https://boingboing.net/2022/06/08/the-fourth-episode-of-obi-wan.html" class="read-more-link">READ THE REST</a>
    </p>
</div></li>
		            <li><div class="next-article">
    <header class="article-header">
        <h2 class="entry-title">
            <a href="https://boingboing.net/2022/06/08/someone-should-deepfake-marjorie-eaton-with-chimp-eyes-into-all-of-palpatines-classic-scenes-and-have-clive-revill-voice-them.html">
				Someone should deepfake Marjorie Eaton with chimp eyes into all of Palpatine's classic scenes and have Clive Revill voice them            </a>
        </h2>
    </header>
    <p>
        <a class="article-image" href="https://boingboing.net/2022/06/08/someone-should-deepfake-marjorie-eaton-with-chimp-eyes-into-all-of-palpatines-classic-scenes-and-have-clive-revill-voice-them.html">
			        <img alt=""
             width="250"
             height="190"
             src="https://i0.wp.com/boingboing.net/wp-content/uploads/2022/06/Screen-Shot-2022-06-08-at-10.02.27-AM.jpg?resize=250%2C190&ssl=1"
             loading="lazy">
	        </a>
		You likely knew that the original Emperor Palpatine in 1980's Empire Strikes Back was performed by Clive Revill, but he in fact provided only the audio—as a quick favor for director Irvin Kershner, a friend in need of a cold, unnerving British voice during the movie's edit. What you see is in fact the actress&hellip;        <a href="https://boingboing.net/2022/06/08/someone-should-deepfake-marjorie-eaton-with-chimp-eyes-into-all-of-palpatines-classic-scenes-and-have-clive-revill-voice-them.html" class="read-more-link">READ THE REST</a>
    </p>
</div></li>
		
		            <li><div class="next-article">
    <header class="article-header">
        <h2 class="entry-title">
            <a href="https://boingboing.net/2022/06/22/light-up-your-life-organically-with-the-pyrodinos-growpro-system.html">
				Light up your life organically with the PyroDinos GrowPro System            </a>
        </h2>
    </header>
    <p>
        <a class="article-image" href="https://boingboing.net/2022/06/22/light-up-your-life-organically-with-the-pyrodinos-growpro-system.html">
			        <img alt=""
             width="250"
             height="190"
             src="https://i0.wp.com/boingboing.net/wp-content/uploads/2022/06/sale_304249_article_image.jpeg?resize=250%2C190&ssl=1"
             loading="lazy">
	        </a>
		Did you know that&nbsp;70% of the oxygen we breathe comes from the ocean, specifically tiny&nbsp;plant-like plankton&nbsp;called&nbsp;Pyrocystis?&nbsp;Well, what if you can grow those tiny&nbsp;Pyrocystis in your own home and enjoy the benefits? Now, that's a possibility, thanks to&nbsp;PyroFarms. For several years, the&nbsp;citizen scientists at PyroFarms have been&nbsp;growing dinoflagellates&nbsp;Pyrocystis. Their&nbsp;mission is to "bring nature's natural wonder, beauty,&hellip;        <a href="https://boingboing.net/2022/06/22/light-up-your-life-organically-with-the-pyrodinos-growpro-system.html" class="read-more-link">READ THE REST</a>
    </p>
</div></li>
		            <li><div class="next-article">
    <header class="article-header">
        <h2 class="entry-title">
            <a href="https://boingboing.net/2022/06/21/cheaper-gas-prices-and-more-await-with-this-mind-blowing-membership.html">
				Cheaper gas prices (and more!) await with this mind-blowing membership            </a>
        </h2>
    </header>
    <p>
        <a class="article-image" href="https://boingboing.net/2022/06/21/cheaper-gas-prices-and-more-await-with-this-mind-blowing-membership.html">
			        <img alt=""
             width="250"
             height="190"
             src="https://i0.wp.com/boingboing.net/wp-content/uploads/2022/06/sale_313669_article_image.jpeg?resize=250%2C190&ssl=1"
             loading="lazy">
	        </a>
		Let's face it: Life is pretty expensive. And while we enjoy splurging on luxury goods, everyday necessities really shouldn't be breaking the bank. That's why&nbsp;memberships to retail warehouses&nbsp;are such a lifesaver. Suddenly, groceries, home goods,&nbsp;furniture,&nbsp;and more are all accessible and inexpensive.&nbsp; One of the best examples of this is Sam's Club — and right now,&hellip;        <a href="https://boingboing.net/2022/06/21/cheaper-gas-prices-and-more-await-with-this-mind-blowing-membership.html" class="read-more-link">READ THE REST</a>
    </p>
</div></li>
		            <li><div class="next-article">
    <header class="article-header">
        <h2 class="entry-title">
            <a href="https://boingboing.net/2022/06/21/give-your-cat-the-gift-of-fully-rechargeable-entertainment-with-cheerble.html">
				Give your cat the gift of fully rechargeable entertainment with Cheerble            </a>
        </h2>
    </header>
    <p>
        <a class="article-image" href="https://boingboing.net/2022/06/21/give-your-cat-the-gift-of-fully-rechargeable-entertainment-with-cheerble.html">
			        <img alt=""
             width="250"
             height="190"
             src="https://i0.wp.com/boingboing.net/wp-content/uploads/2022/06/sale_311885_article_image.jpeg?resize=250%2C190&ssl=1"
             loading="lazy">
	        </a>
		Having a pet at home is one of the great joys in life. Unfortunately, even though many of us work from home, we can't stay with&nbsp;furry friends&nbsp;all the time. Sometimes we have to venture outside and leave our pets at home. If you're lucky enough to&nbsp;have a cat&nbsp;waiting for you to return, the last thing&hellip;        <a href="https://boingboing.net/2022/06/21/give-your-cat-the-gift-of-fully-rechargeable-entertainment-with-cheerble.html" class="read-more-link">READ THE REST</a>
    </p>
</div></li>
		    </ul>
</section>
            </div>

            <div class="tile column is-vertical is-parent">
				
<div id="sidebar1" role="complementary">

	
		
			<div class="sidebarbox widget boing-widget"><div class="ad ad300" style="min-height: 250px;">
	<!-- /5611/boinboing -->
	<!-- Tag ID: boingboing_300x250_300x600_Right_1 -->
	<div class="adslot sidebar" data-freestar-ad="__336x280 __300x600" id="boingboing_300x250_300x600_Right_1">
		<script data-cfasync="false" type="text/javascript">
    		freestar.config.enabled_slots.push({ placementName: "boingboing_300x250_300x600_Right_1", slotId: "boingboing_300x250_300x600_Right_1" });
		</script>
	</div>
</div></div>
		
	
</div>            </div>

        </div>

				<div class="boing-end-of-article-container-on-single-post-pages" id="boing-43656418"><script src="//widget.sellwild.com/boingboing/boingboing-boing-boing.js"></script>
<sellwild></sellwild></div>    </div>

</article>

			
    </main>


<footer class="footer" role="contentinfo">
    <div class="container">
        <div class="columns">

            <div class="column">

                <div class="footer-left">
                    <p>Read the rules you agree to by using this website in our <a href="https://boingboing.net/tos">Terms
                            of
                            Service</a>.</p>
                    <p>We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising
                        program
                        designed to provide a means for us to earn fees by linking to Amazon.com and affiliated
                        sites.</p>
                    <p>Boing Boing uses cookies and analytics trackers, and is supported by advertising, merchandise
                        sales
                        and affiliate links. Read about what we do with the data we gather in our <a
                                href="https://boingboing.net/privacy">Privacy Policy</a>.</p>
                    <p>Who will be eaten first? Our forum rules are detailed in the <a
                                href="https://bbs.boingboing.net/faq">Community Guidelines</a>.</p>
                    <p>Boing Boing is published under <a
                                href="https://creativecommons.org/licenses/by-nc-sa/3.0/deed.en_US">a Creative Commons
                            license</a> except where otherwise noted.</p>
                </div>

            </div>

            <div class="column">

                <div class="footer-right">

                    <ul class="footer-links">
                        <li>
                            <ul>
                                <li><a href="https://twitter.com/frauenfelder">Mark Frauenfelder</a></li>
                                <li><a href="https://twitter.com/pesco">David Pescovitz</a></li>
                                <li><a href="https://twitter.com/beschizza">Rob Beschizza</a></li>
                                <li><a href="https://twitter.com/carla_sinclair">Carla Sinclair</a></li>
                            </ul>
                            <span class="job">Editors</span>
                        </li>
                        <li>
                            <ul>
                                <li>
                                    <a href="https://twitter.com/jlw">Jason Weisberger</a>
                                </li>
                            </ul>
                            <span class="job">Publisher</span>
                        </li>
                        <li>
                            <ul>
                                <li>
                                    <a href="https://twitter.com/orenwolf">Ken Snider</a>
                                </li>
                            </ul>
                            <span class="job">Sysadmin</span>
                        </li>
                        <li>
                            <ul>
                                <li>
                                    <a href="https://boingboing.net/about">About Us</a>
                                </li>
                                <li>
                                    <a href="https://boingboing.net/contact">Contact Us</a>
                                </li>
                                <li>
                                    <a href="https://boingboing.net/advertise">Advertise</a>
                                </li>
                                <li>
                                    <a href="https://bbs.boingboing.net">Forums</a>
                                </li>
                                <li>
                                    <a href="https://store.boingboing.net">Shop</a>
                                </li>
                                <li>
                                    <a href="https://freestar.com/bad-ads/">Report a Bad Ad</a>
                                </li>
                                <li>
                                    <a href="https://bit.ly/boingboingdealssupport">Shop Support</a>
                                </li>
                            </ul>
                        </li>
                    </ul>

                </div>

            </div>

        </div>
    </div>

</footer>

<script>(function(){var advanced_ads_ga_UID="G-X0MTXTYEJ1",advanced_ads_ga_anonymIP=!!1;function AdvAdsAdBlockCounterGA(t){this.UID=t,this.analyticsObject="function"==typeof gtag;var n=this;return this.count=function(){gtag("event","AdBlock",{event_category:"Advanced Ads",event_label:"Yes",non_interaction:!0,send_to:n.UID})},function(){if(!n.analyticsObject){var e=document.createElement("script");e.src="https://www.googletagmanager.com/gtag/js?id="+t,e.async=!0,document.body.appendChild(e),window.dataLayer=window.dataLayer||[],window.gtag=function(){dataLayer.push(arguments)},n.analyticsObject=!0,gtag("js",new Date)}var a={send_page_view:!1,transport_type:"beacon"};window.advanced_ads_ga_anonymIP&&(a.anonymize_ip=!0),gtag("config",t,a)}(),this}window.advanced_ads_check_adblocker=function(t){var n=[],e=null;function a(t){(window.requestAnimationFrame||window.mozRequestAnimationFrame||window.webkitRequestAnimationFrame||function(t){return setTimeout(t,16)}).call(window,t)}return a((function(){var t=document.createElement("div");t.innerHTML="&nbsp;",t.setAttribute("class","ad_unit ad-unit text-ad text_ad pub_300x250"),t.setAttribute("style","width: 1px !important; height: 1px !important; position: absolute !important; left: 0px !important; top: 0px !important; overflow: hidden !important;"),document.body.appendChild(t),a((function(){var a=window.getComputedStyle&&window.getComputedStyle(t),o=a&&a.getPropertyValue("-moz-binding");e=a&&"none"===a.getPropertyValue("display")||"string"==typeof o&&-1!==o.indexOf("about:");for(var i=0,d=n.length;i<d;i++)n[i](e);n=[]}))})),function(t){null!==e?t(e):n.push(t)}}(),advanced_ads_check_adblocker((function(t){t&&new AdvAdsAdBlockCounterGA(advanced_ads_ga_UID).count()}));})();</script><div class="container container-choice-footer-msg"><div class="container-inside"><div id="choice-footer-msg" class="choice-footer-msg"></div></div></div><script type='text/javascript' src='https://c0.wp.com/p/jetpack/11.0/_inc/build/photon/photon.min.js' id='jetpack-photon-js'></script>
<script type='text/javascript' src='https://boingboing.net/wp-content/plugins/advanced-ads-pro/assets/js/advanced-ads-pro.min.js?ver=2.17.2' id='advanced-ads-pro/front-js'></script>
<script type='text/javascript' src='https://boingboing.net/wp-content/themes/boing/assets/scripts/scripts.min.js?ver=6.0' id='site-js-js'></script>
<div class="boing-footer-js" id="boing-34499356"><!-- Begin AA "Footer JS" -->
<!-- Begin Analytics -->
<!-- Facebook Pixel Code -->
<script>!function(f,b,e,v,n,t,s){if(f.fbq)return;n=f.fbq=function(){n.callMethod?n.callMethod.apply(n,arguments):n.queue.push(arguments)};if(!f._fbq)f._fbq=n;n.push=n;n.loaded=!0;n.version='2.0';n.queue=[];t=b.createElement(e);t.async=!0;t.src=v;s=b.getElementsByTagName(e)[0];s.parentNode.insertBefore(t,s)}(window,document,'script','https://connect.facebook.net/en_US/fbevents.js');fbq('init', '1174428159312267');fbq('track', 'PageView');</script>
<noscript><img loading="lazy" height="1" width="1" style="display:none" src="https://www.facebook.com/tr?id=1174428159312267&ev=PageView&noscript=1" /></noscript>
<!-- DO NOT MODIFY -->
<!-- End Facebook Pixel Code -->
<!-- Begin comScore Tag -->
<script>
  var _comscore = _comscore || [];
  _comscore.push({ c1: "2", c2: "7518287" });
  (function() {
    var s = document.createElement("script"), el = document.getElementsByTagName("script")[0]; s.async = true;
    s.src = (document.location.protocol == "https:" ? "https://sb" : "http://b") + ".scorecardresearch.com/beacon.js";
    el.parentNode.insertBefore(s, el);
  })();
</script>
<noscript><img src="https://sb.scorecardresearch.com/p?c1=2&c2=7518287&cv=2.0&cj=1" /></noscript>
<!-- End comScore Tag -->
<!-- Begin Quantcast Tag -->
<script type="text/javascript">
var _qevents = _qevents || [];

(function() {
var elem = document.createElement('script');
elem.src = (document.location.protocol == "https:" ? "https://secure" : "http://edge") + ".quantserve.com/quant.js";
elem.async = true;
elem.type = "text/javascript";
var scpt = document.getElementsByTagName('script')[0];
scpt.parentNode.insertBefore(elem, scpt);
})();

_qevents.push({
qacct:"p-gz35SZjJgwWt-"
});
</script>

<noscript>
<div style="display:none;">
<img loading="lazy" src="//pixel.quantserve.com/pixel/p-gz35SZjJgwWt-.gif" border="0" height="1" width="1" alt="Quantcast"/>
</div>
</noscript>
<!-- End Quantcast tag -->
<!-- End Analytics -->

<!-- record page author for analytics -->
<script>
gtag('Author', 'Jason Weisberger')
var waitForGlobal = function(key, callback) {
  if (window[key]) {
    callback();
  } else {
    setTimeout(function() {
      waitForGlobal(key, callback);
    }, 100);
  }
};
 
waitForGlobal("ga", function() {
  // ga('set', 'dimension1', 'Jason Weisberger');
  ga('send', 'pageview', {
    'dimension1':  'Jason Weisberger'
  });
  console.log("logged author");
});
</script>
<!-- end record page author -->
<!-- End AA "Footer JS" -->
</div><script>window.advads_admin_bar_items = [{"title":"Head JS - CLS","type":"ad"},{"title":"Head JS","type":"placement"},{"title":"Leaderboard - boingboing_728x90_970x90_970x250_320x50_ATF","type":"ad"},{"title":"Leaderboard Below Menu","type":"placement"},{"title":"Primis video, in articles","type":"ad"},{"title":"Primis video: in article content","type":"placement"},{"title":"Primis video, in articles","type":"ad"},{"title":"Primis video: in lower part of article","type":"placement"},{"title":"Single Post Rev Content","type":"ad"},{"title":"Single Post Rev Content","type":"placement"},{"title":"boingboing_300x250_300x600_Right_1","type":"ad"},{"title":"SellWild Article Pages","type":"ad"},{"title":"End of Article Container on Single Post Pages","type":"placement"},{"title":"Footer JS","type":"ad"},{"title":"Footer JS","type":"placement"}];</script><script>!function(){window.advanced_ads_ready_queue=window.advanced_ads_ready_queue||[],advanced_ads_ready_queue.push=window.advanced_ads_ready;for(var d=0,a=advanced_ads_ready_queue.length;d<a;d++)advanced_ads_ready(advanced_ads_ready_queue[d])}();</script><script src='https://stats.wp.com/e-202225.js' defer></script>
<script>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:11.0',blog:'87954168',post:'899228',tz:'-7',srv:'boingboing.net'} ]);
	_stq.push([ 'clickTrackerInit', '87954168', '899228' ]);
</script>

<script type="text/javascript">(function(){window['__CF$cv$params']={r:'71f76a7e89c07fb2',m:'a6vgnp.ZGBx9LcHfKGUP_q5qRTU2iLzN39_eGKhzONg-1655926410-0-AV/23d/OFqkhVrJf/K5tYSZDGSu+uXESWvs+zobV5nuPS2+I4og/zdugX+aOAh2G3xhiCBo7igq5N9JQyQq0WembtjZmdRP1bHNN1eeYvbgosF+BRSblmEE5EFA/EDFk5qsI+a4Spksf+e8QSGsMYABDO5J6u9YKZJnGHO+/dB0KzM3Rlu4AxGWoFVRN+h5fPw==',s:[0xc845e4016d,0x3e607edd58],u:'/cdn-cgi/challenge-platform/h/g'}})();</script><script defer src="https://static.cloudflareinsights.com/beacon.min.js/v652eace1692a40cfa3763df669d7439c1639079717194" integrity="sha512-Gi7xpJR8tSkrpF7aordPZQlW2DLtzUlZcumS8dMQjwDHEnw9I7ZLyiOj/6tZStRBGtGgN6ceN6cMH8z7etPGlw==" data-cf-beacon='{"rayId":"71f76a7e89c07fb2","token":"ef305b4fa5924085acc6719152468be2","version":"2022.6.0","si":100}' crossorigin="anonymous"></script>
</body>

</html>
<!-- plugin=object-cache-pro client=phpredis metric#hits=7328 metric#misses=699 metric#hit-ratio=91.3 metric#bytes=526886 metric#prefetches= metric#store-reads=99 metric#store-writes=2 metric#store-hits=101 metric#store-misses=2 metric#ms-total=298.71 metric#ms-cache=13.88 metric#ms-cache-median=0.11 metric#ms-cache-ratio=4.4 -->
