UK government online disability benefits signup requires IE6

Discuss

30 Responses to “UK government online disability benefits signup requires IE6”

  1. glatt1 says:

    Instead of reading an article about an article about a broken web page, just go right to the broken web page and see if it really is broken.
    http://www.dwp.gov.uk/eservice/need.asp
    it seemed to work for me with Firefox, but I didn’t go through all the hoops.  YMMV

    • foobar says:

      The service does not work properly with Macs or other Unix-based systems even though you may be able to input information.
      You are likely to have problems if you use Internet Explorer 7, 8, 9 and 10, Windows Vista or a smartphone. Clearing temporary internet files may help but you may wish to claim in another way.
      There is also a high risk that if you use browsers not listed below, including Chrome, Safari or Firefox, the service will not display all the questions you need to answer. This is likely to prevent you from successfully completing or submitting the form. You may wish to claim in another way.

      • harry_wood says:

        The site developers did something in a half-assed way which created some problems for some browsers. Then the people writing that text, did it in a half-assed way,  writing that all browsers except the silly one they’re using in their government office (IE6)  will not work. But most disappointingly,  the people writing this article did it in a half-assed way, pretending to reveal a scandal while failing to get to the bottom of what’s actually wrong with the site, or indeed even link to the site properly to let others do so. Can everyone stop doing things in a half-assed way please? kthnxbai

  2. CliffStoll says:

    I misread the headline as requiring IPv6

    So I got the exact opposite take on the story.  But it mapped to the same result: a requirement that’s very challenging for most users.

  3. Kevin Pierce says:

    What the service was designed to work with
    The service was designed to work with the following operating systems and browsers. Many of these are no longer available.

    Microsoft Windows 98:
    * Internet Explorer versions 5.0.1, 5.5 and 6.0
    * Netscape 7.2
    Microsoft Windows ME
    * Internet Explorer version 5.5 and 6.0
    * Netscape 7.2
    Microsoft Windows 2000
    * Internet Explorer version 5.0.1, 5.5 and 6.0
    * Netscape 7.2
    * Firefox 1.0.3
    * Mozilla 1.7.7
    Microsoft Windows XP
    * Internet Explorer 6.0
    * Netscape 7.2
    * Firefox1.0.3
    * Mozilla 1.7.7

    • Nadreck says:

      Well, I have Netscape 7.2 up and running on a OS X Leopard system – which isn’t as old as some of the rest of this stuff.  It works fine with compatible websites although I haven’t tried this one.  The notice quoted above by foobar makes specific mention of a browser and and operating system though.  What kind of spectacular incompetence makes you rely on anything outside of the HTML Posts form the browser?

    • bcsizemo says:

      Netscape 7.2 FTW!

      And IE 5?  FUCKING 5.  I’m not even sure 5 will connect to Windows Update anymore.

  4. annoyingmouse says:

    Since DLA got replaced by PIP today, I shouldn’t imagine that even using a pc from the past would help you apply.

  5. danegeld says:

    I think it does work with modern browsers as well… certainly looks like it works in Safari 5, although I don’t want to sign up to DLA just to check whether your story is accurate. Are there any reports of real people finding the system broken, or is the information page about the required browser just out of date?

    • BradBell says:

      I think the pages display fine at a glance, but if you actually tried to use it, it would crap out. The site says, “if you use browsers not listed below, including Chrome, Safari or Firefox, the service will not display all the questions you need to answer.” Firefox is currently 20 versions too new! You need technology from a time before text messaging. Remember that?

      UK gov has a notorious history for requiring Windows for very many years. Microsoft has historically been their primary vendor. Things did seem to improve over time, and I’m sure by the 21st century, after web standards were established, it became possible to imagine using a Mac, for example. But I wouldn’t be surprised if other gov sites still didn’t work today on a Mac. 

  6. Chuck says:

    Maybe the ownership of a machine with IE6 on it is considered to be the disability.

  7. zachstronaut says:

    I wonder if the specialized assistive technologies that differently abled people depend on (such as Screen Readers) are working as well in newer browsers as they work in IE6?

  8. PickledBeatnik says:

    Hell at least their stuff’s actually computerized. Even wih an outdated browser requirement they’re still lightyears ahead of the V.A.’s sytem.

  9. Neill "Dire" Mitchell says:

    Not everyone has moved to PIP, this site is still a route for the others to claim, or renew DLA. Although it will open in FF, Chrome, IE6+ the form fields do not work, and the claim cannot be progressed past page one. I have found a Chrome plugin to emulate IE6 that just about works.

  10. dhasenan says:

    There’s always IEs4Linux. Additionally, I’ve heard rumors that Microsoft offers specialized VM images that run various versions of Internet Explorer for web developers.

    These are not options that a typical person will know about or be able to work with, though.

  11. Paul McManus says:

    Having worked for a couple of government departments, it’s likely this requirement is based on the IT systems available internally. Most if not all staff are still bound to Windows XP with IE6, either due to cost of upgrading or that legacy IT systems still in use require them.

  12. David says:

    Not as tech savy as many here, but I’m curious how much of the problems are that of lazy web development vs. an honest need to use IE 5 thru 6. I mean I’ve successfully used a user agent in my browser before to get a crappy, old IE only website to work. It’s also failed me when that crappy site might connect to a database & requires the old, non standardized web thinking IE tried to force down everyone’s throats.

    • SamSam says:

      I’m curious how much of the problems are that of lazy web development vs. an honest need to use IE 5 thru 6

      As a web developer and software engineer, let me tell you that this distinction is entirely non-existant. There is simply no case where there is an “honest need” to use IE 5 or 6 that couldn’t be solved by hiring non-lazy developers and managers.

  13. TWX says:

    Why not spoof your browser id string in case the site is making problems in its attempt to tailor the code?

    Did that at work when they blocked some version of something and it worked fine. Though if using IE, spoof Firefox, not older IE…

  14. The site is being replaced for some users by a thing called PIP but only “for new claims for people aged 16-64″
    As I understand it this roll out will not be available to everyone until 2017 http://www.dwp.gov.uk/docs/timetable-for-pip-replacing-dla.pdf

  15. scav says:

    “You are likely to have problems if you use Internet Explorer 7, 8, 9 and 10, Windows Vista or a smartphone.”

    This much is uncontroversial ;)

    However I did sign the petition, because WTF.

  16. SamSam says:

    Wasn’t there a post recently about how the Irish government was soliciting bids to overhaul their web system, and that they explicitly stated that 95% of the selection criterion was price? This is the result of that thinking.

    Someone in the comments mentioned that the British government had won awards for their web system. I think it’s always a little different when you look deeper under the hood.

  17. Thorzdad says:

    This isn’t all that unusual, either in government or in corporate intranets, even today. A lot of underlying systems were built back when IE6 was the 800 lb. gorilla of browsers, and WinXP was all but ubiquitous. Updating them to run on current technologies (while retaining compatibility with legacy systems, because you really need to, especially if your system is aimed at low-income groups who don’t have access to the newest and bestest) simply costs more money than they have in the budget for such things. So, these antiquated requirements linger on.

    • Antinous / Moderator says:

      I worked for Kaiser from 1998 to 2000, when they were just updating to Windows 3.0. Going to work was like getting in a time machine.

  18. Camp Freddie says:

    Today, I’ve been installing an XP virtual machine on Windows 7. So, my virtual machine will meet the requirements, right?

    Wrong! The first thing Windows XP does is prompt you for windows update, and literally the first update is to switch IE6 for IE8 (since windows update uses IE to connect and immediately tells you that you need to upgrade).So, anyone with an internet-connected 10-year-old XP machine will STILL not be able to use the DWP site unless they’ve deactivate windows updates.And if they’ve been running an un-updated XP machine for 10 years, it’s pretty damn likely that their machine is full of viruses, since I doubt they’ll have kept their AV/Firewall up-to-date.

  19. GVDub says:

    Then again, it may be that the disadvantaged are less likely to have easy access to a newer computer running a modern OS. It’s easy to forget which side of the digital divide you live on.

  20. Invisible Pinoy says:

    maybe you can setup a kiosk with a machine that has IE 6 for this purpose.

Leave a Reply