<!DOCTYPE html>
<html lang="en-US">
<head>
<meta charset="UTF-8">
<meta name="viewport" content="width=device-width">
<title>Three years after the W3C approved a DRM standard, it&#039;s no longer possible to make a functional indie browser / Boing Boing</title>

<meta name="viewport" content="initial-scale=1">
<meta property="twitter:account_id" content="5971922" />
<meta property="fb:admins" content="1219680052" />
<meta property="og:site_name" content="Boing Boing" />

<link rel="apple-touch-icon" href="https://boingboing.net/wp-content/themes/bng/i/apple-touch-icon.png"/>     

<script src="https://ajax.googleapis.com/ajax/libs/webfont/1.5.18/webfont.js"></script>
<script>
  WebFont.load({
    google: {
      families: ['Raleway:600,800,400','Libre+Baskerville:400,700,400italic']
    }
  });
</script>


<link rel="stylesheet" href="https://boingboing.net/wp-content/themes/bng/style.css?v=1.3" type="text/css" media="all" />

 

  	

	<meta itemprop="name" content="Three years after the W3C approved a DRM standard, it&#039;s no longer possible to make a functional indie browser" />
	<meta itemprop="headline" content="Three years after the W3C approved a DRM standard, it&#039;s no longer possible to make a functional indie browser" />
	<meta itemprop="author" content="" />
	<meta itemprop="description" content="Three years after the W3C approved a DRM standard, it&#039;s no longer possible to make a functional indie browser" />
	<link itemprop="url" href="https://boingboing.net/2020/01/08/rip-open-web-platform.html" />
    <link itemprop="thumbnailUrl" href="https://media.boingboing.net/wp-content/uploads/2020/01/prison-553836_1920.jpg" />


<!-- AD CODE -->

<script async='async' src='https://www.googletagservices.com/tag/js/gpt.js'></script>
<script>

  var pageType = 'Blog'; // 'Feature' or 'Homepage' or 'Blog'

  window.googletag = window.googletag || {};
  googletag.cmd = googletag.cmd || [];

  </script>

    <!-- UnrulyX tag -->
  <script>var unruly=window.unruly || {};unruly.native=unruly.native || {};unruly.native.siteId=1021419;</script>
  <script src="//video.unrulymedia.com/native/native-loader.js"></script>
  
  <!-- Facebook Pixel Code -->
  <script>!function(f,b,e,v,n,t,s){if(f.fbq)return;n=f.fbq=function(){n.callMethod?n.callMethod.apply(n,arguments):n.queue.push(arguments)};if(!f._fbq)f._fbq=n;n.push=n;n.loaded=!0;n.version='2.0';n.queue=[];t=b.createElement(e);t.async=!0;t.src=v;s=b.getElementsByTagName(e)[0];s.parentNode.insertBefore(t,s)}(window,document,'script','https://connect.facebook.net/en_US/fbevents.js');fbq('init', '1174428159312267');fbq('track', 'PageView');</script>
  <noscript><img height="1" width="1" style="display:none" src="https://www.facebook.com/tr?id=1174428159312267&ev=PageView&noscript=1" /></noscript>
  <!-- DO NOT MODIFY -->
  <!-- End Facebook Pixel Code -->

  <!-- freestar -->
    <script data-cfasync="false" type="text/javascript">
    var freestar = freestar || {};
    freestar.hitTime = Date.now();
    freestar.queue = freestar.queue || [];
    freestar.config = freestar.config || {};
    freestar.debug = window.location.search.indexOf('fsdebug') === -1 ? false : true;

    // Tag IDs set here, must match Tags served in the Body for proper setup
    freestar.config.enabled_slots = [
      "boingboing_728x90_970x90_970x250_320x50_ATF",
      "boingboing_468x60_300x250_InContent",
      "boingboing_1x1_gumgum-inimage",
              "boingboing_300x250_300x600_Right_1",
        "boingboing_300x250_300x600_Right_2",
        "boingboing_300x250_300x600_Right_3"
          ];

    freestar.queue.push(function() {
      googletag.pubads().setTargeting('PostID','761695');
      googletag.pubads().setTargeting('Category',["browser wars","competition","Copyfight","drm","eme","late stage capitalism","monopolism","perpetual internet domination licenses","standards","W3C"]);
      googletag.pubads().setTargeting('pagetype','');
    });

    !function(a,b){var c=b.getElementsByTagName("script")[0],d=b.createElement("script"),e="https://a.pub.network/boingboing-net";e+=freestar.debug?"/qa/pubfig.min.js":"/pubfig.min.js",d.async=!0,d.src=e,c.parentNode.insertBefore(d,c)}(window,document);
  </script>
  
  <!-- END OF AD CODE -->


<!-- Jetpack Site Verification Tags -->
<meta name="google-site-verification" content="2Z2CdDZoCt3kedjrHnPrbA3HjYnoXwwgy2pjFo552ws" />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="Boing Boing &raquo; Feed" href="https://boingboing.net/feed" />
<link rel="alternate" type="application/rss+xml" title="Boing Boing &raquo; Comments Feed" href="https://boingboing.net/comments/feed" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/boingboing.net\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.3.2"}};
			!function(e,a,t){var r,n,o,i,p=a.createElement("canvas"),s=p.getContext&&p.getContext("2d");function c(e,t){var a=String.fromCharCode;s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,e),0,0);var r=p.toDataURL();return s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,t),0,0),r===p.toDataURL()}function l(e){if(!s||!s.fillText)return!1;switch(s.textBaseline="top",s.font="600 32px Arial",e){case"flag":return!c([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])&&(!c([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!c([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]));case"emoji":return!c([55357,56424,55356,57342,8205,55358,56605,8205,55357,56424,55356,57340],[55357,56424,55356,57342,8203,55358,56605,8203,55357,56424,55356,57340])}return!1}function d(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(i=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},o=0;o<i.length;o++)t.supports[i[o]]=l(i[o]),t.supports.everything=t.supports.everything&&t.supports[i[o]],"flag"!==i[o]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[i[o]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(r=t.source||{}).concatemoji?d(r.concatemoji):r.wpemoji&&r.twemoji&&(d(r.twemoji),d(r.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='jetpack_css-css'  href='https://c0.wp.com/p/jetpack/8.0/css/jetpack.css' type='text/css' media='all' />
<link rel='https://api.w.org/' href='https://boingboing.net/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://boingboing.net/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://media.boingboing.net/wp-includes/wlwmanifest.xml" /> 
<link rel='prev' title='TeenVogue/Facebook/2020 Election Security thing blows up badly' href='https://boingboing.net/2020/01/08/teenvogue-facebook-sponsored-c.html' />
<link rel='next' title='A short video history of Rasputin' href='https://boingboing.net/2020/01/08/a-short-video-history-of-raspu.html' />
<meta name="generator" content="WordPress 5.3.2" />
<link rel="canonical" href="https://boingboing.net/2020/01/08/rip-open-web-platform.html" />
<link rel='shortlink' href='https://boingboing.net/?p=761695' />
<link rel="alternate" type="application/json+oembed" href="https://boingboing.net/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fboingboing.net%2F2020%2F01%2F08%2Frip-open-web-platform.html" />
<link rel="alternate" type="text/xml+oembed" href="https://boingboing.net/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fboingboing.net%2F2020%2F01%2F08%2Frip-open-web-platform.html&#038;format=xml" />
<link rel="apple-touch-icon" sizes="180x180" href="/wp-content/uploads/fbrfg/apple-touch-icon.png?v=2.1">
<link rel="icon" type="image/png" sizes="32x32" href="/wp-content/uploads/fbrfg/favicon-32x32.png?v=2.1">
<link rel="icon" type="image/png" sizes="16x16" href="/wp-content/uploads/fbrfg/favicon-16x16.png?v=2.1">
<link rel="manifest" href="/wp-content/uploads/fbrfg/site.webmanifest?v=2.1">
<link rel="mask-icon" href="/wp-content/uploads/fbrfg/safari-pinned-tab.svg?v=2.1" color="#ff0000">
<link rel="shortcut icon" href="/wp-content/uploads/fbrfg/favicon.ico?v=2.1">
<meta name="msapplication-TileColor" content="#b91d47">
<meta name="msapplication-config" content="/wp-content/uploads/fbrfg/browserconfig.xml?v=2.1">
<meta name="theme-color" content="#ffffff">
<link rel='dns-prefetch' href='//i0.wp.com'/>
<link rel='dns-prefetch' href='//i1.wp.com'/>
<link rel='dns-prefetch' href='//i2.wp.com'/>
<link rel='dns-prefetch' href='//c0.wp.com'/>
<style type='text/css'>img#wpstats{display:none}</style><meta name="description" content="Back in 2017, the World Wide Web Consortium (W3C) approved the most controversial standard in its long history: Encrypted Media Extensions, or EME, which enabled Netflix and other big media companies to use DRM despite changes to browsers extensions that eliminated the kinds of deep hooks that DRM requires. At the time, the Electronic Frontier&hellip;" />
<link rel="amphtml" href="https://boingboing.net/2020/01/08/rip-open-web-platform.html/amp">
<!-- Jetpack Open Graph Tags -->
<meta property="og:type" content="article" />
<meta property="og:title" content="Three years after the W3C approved a DRM standard, it&#039;s no longer possible to make a functional indie browser" />
<meta property="og:url" content="https://boingboing.net/2020/01/08/rip-open-web-platform.html" />
<meta property="og:description" content="Back in 2017, the World Wide Web Consortium (W3C) approved the most controversial standard in its long history: Encrypted Media Extensions, or EME, which enabled Netflix and other big media compani…" />
<meta property="article:published_time" content="2020-01-08T18:34:23+00:00" />
<meta property="article:modified_time" content="2020-01-08T18:34:23+00:00" />
<meta property="og:site_name" content="Boing Boing" />
<meta property="og:image" content="https://i2.wp.com/media.boingboing.net/wp-content/uploads/2020/01/prison-553836_1920.jpg?fit=1000%2C667&amp;ssl=1" />
<meta property="og:image:width" content="1000" />
<meta property="og:image:height" content="667" />
<meta property="og:locale" content="en_US" />
<meta name="twitter:creator" content="@BoingBoing" />
<meta name="twitter:site" content="@boingboing" />
<meta name="twitter:text:title" content="Three years after the W3C approved a DRM standard, it&#039;s no longer possible to make a functional indie browser" />
<meta name="twitter:image" content="https://i2.wp.com/media.boingboing.net/wp-content/uploads/2020/01/prison-553836_1920.jpg?fit=1000%2C667&#038;ssl=1&#038;w=640" />
<meta name="twitter:card" content="summary_large_image" />

<!-- End Jetpack Open Graph Tags -->
<link rel="icon" href="https://i0.wp.com/media.boingboing.net/wp-content/uploads/2018/04/apple-touch-icon-1.png?fit=32%2C32&#038;ssl=1" sizes="32x32" />
<link rel="icon" href="https://i0.wp.com/media.boingboing.net/wp-content/uploads/2018/04/apple-touch-icon-1.png?fit=158%2C158&#038;ssl=1" sizes="192x192" />
<link rel="apple-touch-icon-precomposed" href="https://i0.wp.com/media.boingboing.net/wp-content/uploads/2018/04/apple-touch-icon-1.png?fit=158%2C158&#038;ssl=1" />
<meta name="msapplication-TileImage" content="https://i0.wp.com/media.boingboing.net/wp-content/uploads/2018/04/apple-touch-icon-1.png?fit=158%2C158&#038;ssl=1" />
<script>
  (function (s,o,n,a,r,i,z,e) {s['StackSonarObject']=r;s[r]=s[r]||function(){
  (s[r].q=s[r].q||[]).push(arguments)},s[r].l=1*new Date();i=o.createElement(n),
  z=o.getElementsByTagName(n)[0];i.async=1;i.src=a;z.parentNode.insertBefore(i,z)
  })(window,document,'script','https://www.stack-sonar.com/ping.js','stackSonar');

  stackSonar('stack-connect-wp', "6Mp0z_hYN4uKoN7SaPiUOQ");
</script>

<script type="text/javascript" src="//s.ntv.io/serve/load.js" async></script>
<meta http-equiv="X-UA-Compatible" content="IE=10" />

</head>
<!-- body class="post-template-default single single-post postid-761695 single-format-standard" -->
    <!-- Header -->
   

	<body class="post-template-default single single-post postid-761695 single-format-standard single-blog">

<div id="container">




<div class="navbyline">
	<span class="logo"><a href="https://boingboing.net"><img src="https://boingboing.net/wp-content/themes/bng/i/logo.png" class=""></a></span> /
	<span class="author"><a href="https://boingboing.net/author/cory_doctorow_1">Cory Doctorow</a></span> /
	<span class="date">10:34 am Wed</span>
	 <span id="metadata" style="">
		 Jan 8, 2020 	 <span>
</div>

<div id="leaderboard">
	<!-- /5611/boinboing -->
	<!-- Tag ID: boingboing_728x90_970x90_970x250_320x50_ATF -->
	<div class="adslot leaderboard" id="boingboing_728x90_970x90_970x250_320x50_ATF">
		<script data-cfasync="false" type="text/javascript">
			freestar.queue.push(function () { googletag.display('boingboing_728x90_970x90_970x250_320x50_ATF'); });
		</script>
	</div>
</div>


<div id="headline">
	<h1>Three years after the W3C approved a DRM standard, it's no longer possible to make a functional indie browser</h1>
</div>




	<div class="featuredimage">
		<img width="1000" height="667" src="https://media.boingboing.net/wp-content/uploads/2020/01/prison-553836_1920.jpg" class="attachment-post-thumbnail size-post-thumbnail wp-post-image" alt="" srcset="https://i2.wp.com/media.boingboing.net/wp-content/uploads/2020/01/prison-553836_1920.jpg?w=1000&amp;ssl=1 1000w, https://i2.wp.com/media.boingboing.net/wp-content/uploads/2020/01/prison-553836_1920.jpg?resize=600%2C400&amp;ssl=1 600w, https://i2.wp.com/media.boingboing.net/wp-content/uploads/2020/01/prison-553836_1920.jpg?resize=930%2C620&amp;ssl=1 930w, https://i2.wp.com/media.boingboing.net/wp-content/uploads/2020/01/prison-553836_1920.jpg?resize=300%2C200&amp;ssl=1 300w, https://i2.wp.com/media.boingboing.net/wp-content/uploads/2020/01/prison-553836_1920.jpg?resize=768%2C512&amp;ssl=1 768w" sizes="(max-width: 1000px) 100vw, 1000px" />			</div>
	


<div id="sidebar">




	<div class="ad ad300">
		<!-- /5611/boinboing -->
		<!-- Tag ID: boingboing_300x250_300x600_Right_1 -->
		<div class="adslot sidebar" id="boingboing_300x250_300x600_Right_1">
			<script data-cfasync="false" type="text/javascript">
				freestar.queue.push(function () { googletag.display('boingboing_300x250_300x600_Right_1'); });
			</script>
		</div>
	</div>

	<div id="widgets">
				<div class="pre-widget">
<!--
			<p><strong>Widgets</strong></p>
			<p>DEBUG: Widgets are active
-->
		</div>
			</div>

	<div class="ad ad300">
		<!-- /5611/boinboing -->
		<!-- Tag ID: boingboing_300x250_300x600_Right_2 -->
		<div class="adslot sidebar" id="boingboing_300x250_300x600_Right_2">
			<script data-cfasync="false" type="text/javascript">
				freestar.queue.push(function () { googletag.display('boingboing_300x250_300x600_Right_2'); });
			</script>
		</div>
	</div>

	<div class="ad ad300">
		<div id="followbb" class="sidebarbox">
			<h3>Follow Us</h3>
			<h4><a class="twitter" href="https://twitter.com/boingboing">Twitter</a> /
				 <a class="facebook" href="https://www.facebook.com/boingboing">Facebook</a> /
				 <a class="rss" href="https://boingboing.net/feed">RSS</a>
			</h4>
		</div>
	</div>

	<div class="ad ad300 stickme">
		<!-- /5611/boinboing -->
		<!-- Tag ID: boingboing_300x250_300x600_Right_3 -->
		<div class="adslot sidebar" id="boingboing_300x250_300x600_Right_3">
			<script data-cfasync="false" type="text/javascript">
				freestar.queue.push(function () { googletag.display('boingboing_300x250_300x600_Right_3'); });
			</script>
		</div>
	</div>

</div>



<div id="story">



<p>
Back in 2017, the World Wide Web Consortium (W3C) <a href="https://boingboing.net/2017/11/27/piracy-is-always-a-smokescreen.html">approved the most controversial standard in its long history</a>: Encrypted Media Extensions, or <a href="https://boingboing.net/tag/eme">EME</a>, which enabled Netflix and other big media companies to use DRM despite changes to browsers extensions that eliminated the kinds of deep hooks that DRM requires.
</p>
</p>

		<div class="mobilead">
			<!-- /5611/boinboing -->
			<div class="adslot notinuse" id="slot_not_in_use_1"></div>
		</div>

		<span id="more-761695"></span>
<P>
At the time, the Electronic Frontier Foundation <a href="https://www.eff.org/deeplinks/2017/09/open-letter-w3c-director-ceo-team-and-membership">warned</a> that, by approving its first non-unanimous standard, the W3C would give control over browser design to the big browser companies, and two years later, that warning has fully proven out.
<P>
First, Google -- whose proprietary technology must be licensed in most cases if you want to make a new browser -- <a href="https://boingboing.net/2019/05/29/hoarding-software-freedom.html">stopped permitting open source browsers</a> to use its DRM technology, effectively requiring all new browsers to be proprietary.
<P>
Now, Microsoft and Apple -- the remaining two vendors who can also supply the proprietary components that Google won't license -- have effectively stopped answering the phone when small browser creators call. Microsoft might let you license its tools if you pay them $10,000 to submit an application and then $0.35 for every browser you ship.

<P>
Samuel Maddock has been trying to create a rival "indie" browser, and has been to each of the EME DRM vendors <a href="https://blog.samuelmaddock.com/posts/the-end-of-indie-web-browsers/">and has been sent away by all of them</a>.
<P>
The W3C's mission is to create an <a href="https://www.w3.org/wiki/Open_Web_Platform">Open Web Platform</a>" so that "everyone has the right to implement a software component of the Web without requiring any approvals or waiving license fees." When EME was approved, we warned that they were effectively ending the Open Web era by putting every future browser developer at the mercy of three giant incumbent browser developers.
<P>
And here we are.
<P>
Next up: watch for lurking software bugs in EME that compromise user security and privacy to go unreported while they are exploited by criminals and spies. DRM laws like Section 1201 of the DMCA allow software vendors to threaten whistleblowers who disclose bugs without permission with both civil and criminal liability, and the W3C specifically turned down <em>every single proposal</em> to make its members promise not to abuse this power -- even when those members signalled that they viewed the power to decide who could criticize their products as a feature of the EME process, and not a bug.
<P>
The web is not merely reduced to <a href="https://twitter.com/tveastman/status/1069674780826071040">five giant sites, each filled from screenshots from the other four</a>, it's also a near-monoculture of browsers, almost all of them controlled by tech giants who have been complicit in both commercial and state surveillance, including <a href="https://boingboing.net/2018/05/21/apple-bends-to-chinese-governm.html">surveillance by the world's most notorious torturing and murdering autocracies</a>.
<p>
The W3C's decision to hand these monopolists perpetual Internet Domination Licenses was the gravest mistake in its history, just when we needed its principled leadership the most. We are living in the aftermath of that decision today and things will get worse long before they get better.
<P>
Meanwhile, the W3C's <a href="https://www.w3.org/2017/07/EME-backgrounder.html">own page on EME</a> is completely silent on the most controversial standarization process in the organization's history.

<blockquote>
<P>
Since the introduction of EME to web standards, the ability for new browsers to compete has become restricted by gatekeepers, which goes against the promises of the platform.
<p>
   <em> Using the Open Web Platform, everyone has the right to implement a software componet of the Web without requiring any approvals or waiving license fees.</em>
<p>
Yes, the EME standard can be implemented by anyone, but it's moot when the requirement of a CDM says otherwise.
</blockquote>

<p>
<a href="https://blog.samuelmaddock.com/posts/the-end-of-indie-web-browsers/">The End of Indie Web Browsers: You Can (Not) Compete</a> [Samuel Maddock]

</p>

	<div class="share">
		
	<h3>
		<a class="facebook" href="https://www.facebook.com/sharer.php?u=https%3A%2F%2Fboingboing.net%2F2020%2F01%2F08%2Frip-open-web-platform.html" target="_blank">SHARE</a> /
		<a class="twitter" href="https://twitter.com/intent/tweet?text=Three+years+after+the+W3C+approved+a+DRM+standard%2C+it%27s+no+longer+possible+to+make+a+functional+indie+browser+https%3A%2F%2Fboingboing.net%2F2020%2F01%2F08%2Frip-open-web-platform.html&original_referer=https%3A%2F%2Fboingboing.net%2F2020%2F01%2F08%2Frip-open-web-platform.html" target="_blank">TWEET</a> /
		<a class="bbs" href="https://bbs.boingboing.net/t/three-years-after-the-w3c-approved-a-drm-standard-its-no-longer-possible-to-make-a-functional-indie-browser/158552">14 COMMENTS</a>
			</h3>
	
	
<h3 class="thetags" style="text-transform:uppercase;margin:1em 0">
	<a href="https://boingboing.net/tag/browser-wars" rel="tag">browser wars</a> / <a href="https://boingboing.net/tag/competition" rel="tag">competition</a> / <a href="https://boingboing.net/tag/copyfight" rel="tag">Copyfight</a> / <a href="https://boingboing.net/tag/drm" rel="tag">drm</a> / <a href="https://boingboing.net/tag/eme" rel="tag">eme</a> / <a href="https://boingboing.net/tag/late-stage-capitalism" rel="tag">late stage capitalism</a> / <a href="https://boingboing.net/tag/monopolism" rel="tag">monopolism</a> / <a href="https://boingboing.net/tag/perpetual-internet-domination" rel="tag">perpetual internet domination licenses</a> / <a href="https://boingboing.net/tag/standards" rel="tag">standards</a> / <a href="https://boingboing.net/tag/w3c" rel="tag">W3C</a></h3>
		
		
</div>
<!--
<div id="share-author" style="border:5px solid silver;margin-bottom:1em;padding:1em">


	<img alt='' src='https://secure.gravatar.com/avatar/bdd2b71f7e0f6b5e4e2fdf809cd8e3dc?s=125&#038;d%5Bclass%5D=avatar&#038;r=pg' srcset='https://secure.gravatar.com/avatar/bdd2b71f7e0f6b5e4e2fdf809cd8e3dc?s=250&#038;d%5Bclass%5D=avatar&#038;r=pg 2x' class='avatar avatar-125 photo' height='125' width='125' />	
	
	<h2>Cory Doctorow</h2>
	<p style="overflow:auto;font-family:raleway,sans-serif;">I write books. My latest are: a YA graphic novel called <a href="http://www.amazon.com/exec/obidos/ASIN/1596436581/downandoutint-20">In Real Life</a> (with Jen Wang); a nonfiction book about the arts and the Internet called <a href="http://www.amazon.com/exec/obidos/ASIN/1940450284/downandoutint-20">Information Doesn't Want to Be Free: Laws for the Internet Age</a> (with introductions by Neil Gaiman and Amanda Palmer) and a YA science fiction novel called <a href="http://craphound.com/homeland">Homeland</a> (it's the sequel to <a href="http://craphound.com/littlebrother">Little Brother</a>). I <a href="https://craphound.com/?page_id=4667">speak all over the place</a> and I <a href="https://twitter.com/doctorow">tweet</a> and <a href="http://mostlysignssomeportents.tumblr.com/">tumble</a>, too.
</div>
		
		
-->

<!-- vuukle powerbar -->
  <div class='vuukle-powerbar'></div>

			<!-- /5611/boinboing -->
			<!-- Tag ID: boingboing_468x60_300x250_InContent -->
			<div class="admargin adslot incontent" id="boingboing_468x60_300x250_InContent">
				<script data-cfasync="false" type="text/javascript">
					freestar.queue.push(function () { googletag.display('boingboing_468x60_300x250_InContent'); });
				</script>
			</div>

<div class="separator" style="margin:1em auto 2em auto;border:4px solid red;padding:1em;max-width:1000px;text-align:center;">

<!-- Begin MailChimp Signup Form -->
<link href="//cdn-images.mailchimp.com/embedcode/horizontal-slim-10_7.css" rel="stylesheet" type="text/css">
<style type="text/css">
	#mc_embed_signup{background:#fff; clear:left; font:14px Helvetica,Arial,sans-serif; width:100%;}
</style>
<style type="text/css">
	#mc-embedded-subscribe-form input[type=checkbox]{display: inline; width: auto;margin-right: 10px;}
	#mergeRow-gdpr {margin-top: 20px;}
	#mergeRow-gdpr fieldset label {font-weight: normal;}
	#mc-embedded-subscribe-form .mc_fieldset{border:none;min-height: 0px;padding-bottom:0px;}
        #mc-embedded-subscribe-form input[type=submit]{background-color: red; color: white;}
</style>
<div id="mc_embed_signup">
<form action="https://boingboing.us2.list-manage.com/subscribe/post?u=0e91f8e7df61da4bff2bd9b1f&amp;id=8c5d27370d" method="post" id="mc-embedded-subscribe-form" name="mc-embedded-subscribe-form" class="validate" target="_blank" novalidate>
    <div id="mc_embed_signup_scroll">
	<label for="mce-EMAIL">GET THE BOING BOING NEWSLETTER</label>
	<input type="email" value="" name="EMAIL" class="email" id="mce-EMAIL" placeholder="email address" required>
    <div style="position: absolute; left: -5000px;" aria-hidden="true"><input type="text" name="b_0e91f8e7df61da4bff2bd9b1f_8c5d27370d" tabindex="-1" value=""></div>
    <div class="clear"><input type="submit" value="Subscribe" name="subscribe" id="mc-embedded-subscribe" class="button"></div>
    </div>
</form>
</div>

<!--End mc_embed_signup-->
</div>


</div>

<!-- Revcontent -->
<div id="rcjsload_75ea89"></div>
<script type="text/javascript">
	(function() {
		var referer="";try{if(referer=document.referrer,"undefined"==typeof referer||""==referer)throw"undefined"}catch(exception){referer=document.location.href,(""==referer||"undefined"==typeof referer)&&(referer=document.URL)}referer=referer.substr(0,700);
		var rcds = document.getElementById("rcjsload_75ea89");
		var rcel = document.createElement("script");
		rcel.id = 'rc_' + Math.floor(Math.random() * 1000);
		rcel.type = 'text/javascript';
		rcel.src = "//trends.revcontent.com/serve.js.php?w=113901&t="+rcel.id+"&c="+(new Date()).getTime()+"&width="+(window.outerWidth || document.documentElement.clientWidth)+"&referer="+encodeURIComponent(referer);
		rcel.async = true;
		rcds.appendChild(rcel);
	})();
</script>
<!-- second unit -->
<div id="rc-widget-6c87ee" data-rc-widget data-widget-host="habitat" data-endpoint="//trends.revcontent.com" data-widget-id="115370"></div>
<script type="text/javascript" src="//assets.revcontent.com/master/delivery.js" defer="defer"></script>
<!-- end Revcontent -->

<!-- vuukle newsfeed -->
  <div id='vuukle-newsfeed'></div> 

<!--googleoff: all-->


<div id="next-post-thumbnails">


		
	<div class="nextstory">
	
		<h2><a href="https://boingboing.net/2020/01/06/welcome-foolish-mortals.html?utm_source=moreatbb&utm_medium=nextpost&utm_campaign=nextpostthumbnails" onclick="clickTrack(this.href, 'Next Post Button', 'Next Post Thumbnails');">1975 Disneyland Haunted Mansion Standard Operating Procedures manual</a></h2>
				
		<a href="https://boingboing.net/2020/01/06/welcome-foolish-mortals.html?utm_source=moreatbb&utm_medium=nextpost&utm_campaign=nextpostthumbnails" onclick="clickTrack(this.href, 'Next Post Button', 'Next Post Thumbnails');"><img width="600" height="504" src="https://i1.wp.com/media.boingboing.net/wp-content/uploads/2020/01/fff.jpg?fit=600%2C504&amp;ssl=1" class="attachment-medium size-medium wp-post-image" alt="" srcset="https://i1.wp.com/media.boingboing.net/wp-content/uploads/2020/01/fff.jpg?w=800&amp;ssl=1 800w, https://i1.wp.com/media.boingboing.net/wp-content/uploads/2020/01/fff.jpg?resize=600%2C504&amp;ssl=1 600w, https://i1.wp.com/media.boingboing.net/wp-content/uploads/2020/01/fff.jpg?resize=300%2C252&amp;ssl=1 300w, https://i1.wp.com/media.boingboing.net/wp-content/uploads/2020/01/fff.jpg?resize=768%2C645&amp;ssl=1 768w" sizes="(max-width: 600px) 100vw, 600px" /></a>
		<p>If you ever find yourself time-traveling to 1975 and need to impersonate a Disneyland Haunted Mansion ride-operator, we've got you covered: just remember that in 1975, food and drinks were absolutely not allowed past the main gate, and that E-tickets should be torn in half and placed in the ticket box. (Thanks, Changa!)		<h3><a href="https://boingboing.net/2020/01/06/welcome-foolish-mortals.html">READ THE REST</a></h3>

	</div>

		
	
	<div class="nextstory">
	
		<h2><a href="https://boingboing.net/2020/01/01/irving-berlin-george-gershwin.html?utm_source=moreatbb&utm_medium=nextpost&utm_campaign=nextpostthumbnails" onclick="clickTrack(this.href, 'Next Post Button', 'Next Post Thumbnails');">Public Domain Game Jam: what games can you design with the bounty of 1924?</a></h2>
				
		<a href="https://boingboing.net/2020/01/01/irving-berlin-george-gershwin.html?utm_source=moreatbb&utm_medium=nextpost&utm_campaign=nextpostthumbnails" onclick="clickTrack(this.href, 'Next Post Button', 'Next Post Thumbnails');"><img width="600" height="476" src="https://i1.wp.com/media.boingboing.net/wp-content/uploads/2020/01/dyfuYq.png?fit=600%2C476&amp;ssl=1" class="attachment-medium size-medium wp-post-image" alt="" srcset="https://i1.wp.com/media.boingboing.net/wp-content/uploads/2020/01/dyfuYq.png?w=1575&amp;ssl=1 1575w, https://i1.wp.com/media.boingboing.net/wp-content/uploads/2020/01/dyfuYq.png?resize=600%2C476&amp;ssl=1 600w, https://i1.wp.com/media.boingboing.net/wp-content/uploads/2020/01/dyfuYq.png?resize=930%2C738&amp;ssl=1 930w, https://i1.wp.com/media.boingboing.net/wp-content/uploads/2020/01/dyfuYq.png?resize=300%2C238&amp;ssl=1 300w, https://i1.wp.com/media.boingboing.net/wp-content/uploads/2020/01/dyfuYq.png?resize=768%2C610&amp;ssl=1 768w, https://i1.wp.com/media.boingboing.net/wp-content/uploads/2020/01/dyfuYq.png?resize=1536%2C1219&amp;ssl=1 1536w" sizes="(max-width: 600px) 100vw, 600px" /></a>
		<p>Randy Lubin (previously) writes, "New work is entering the public domain and Mike Masnick and I are hosting a game jam to celebrate. Designers have all of January to design analog and digital games about, inspired by, or remixing works from 1924. We have amazing judges, great prizes, and are excited to see what you [&hellip;]		<h3><a href="https://boingboing.net/2020/01/01/irving-berlin-george-gershwin.html">READ THE REST</a></h3>

	</div>

		
	
	<div class="nextstory">
	
		<h2><a href="https://boingboing.net/2020/01/01/godley-and-creme.html?utm_source=moreatbb&utm_medium=nextpost&utm_campaign=nextpostthumbnails" onclick="clickTrack(this.href, 'Next Post Button', 'Next Post Thumbnails');">Using Stylegan to age everyone in 1985's hit video "Cry"</a></h2>
				
		<a href="https://boingboing.net/2020/01/01/godley-and-creme.html?utm_source=moreatbb&utm_medium=nextpost&utm_campaign=nextpostthumbnails" onclick="clickTrack(this.href, 'Next Post Button', 'Next Post Thumbnails');"><img width="320" height="180" src="https://i0.wp.com/media.boingboing.net/wp-content/uploads/2020/01/animation.gif?fit=320%2C180&amp;ssl=1" class="attachment-medium size-medium wp-post-image" alt="" /></a>
		<p>Shardcore (previously) writes, "I took Godley & Creme's seminal 1985 video and sent it through a StyleGAN network."		<h3><a href="https://boingboing.net/2020/01/01/godley-and-creme.html">READ THE REST</a></h3>

	</div>

		

		<p>
		

		
		<div class="nextstory">
	
		<h2><a href="https://boingboing.net/2020/01/08/easily-edit-pdf-files-with-the.html?utm_source=moreatbb&utm_medium=nextpost&utm_campaign=nextpostthumbnails" onclick="clickTrack(this.href, 'Next Post Button', 'Next Post Thumbnails');">Easily edit PDF files with the award-winning PDF Expert now on sale for 62% off</a></h2>
				
		<a href="https://boingboing.net/2020/01/08/easily-edit-pdf-files-with-the.html?utm_source=moreatbb&utm_medium=nextpost&utm_campaign=nextpostthumbnails" onclick="clickTrack(this.href, 'Next Post Button', 'Next Post Thumbnails');"><img width="600" height="450" src="https://i0.wp.com/media.boingboing.net/wp-content/uploads/2020/01/sale_24411_primary_image.jpg?fit=600%2C450&amp;ssl=1" class="attachment-medium size-medium wp-post-image" alt="" srcset="https://i0.wp.com/media.boingboing.net/wp-content/uploads/2020/01/sale_24411_primary_image.jpg?w=630&amp;ssl=1 630w, https://i0.wp.com/media.boingboing.net/wp-content/uploads/2020/01/sale_24411_primary_image.jpg?resize=600%2C450&amp;ssl=1 600w, https://i0.wp.com/media.boingboing.net/wp-content/uploads/2020/01/sale_24411_primary_image.jpg?resize=300%2C225&amp;ssl=1 300w" sizes="(max-width: 600px) 100vw, 600px" /></a>
		
		<p><p>It&#8217;s hard to find a web-based profession — or any profession, for that matter — that doesn&#8217;t require you to deal with PDFs. They&#8217;re universally recognized, they&#8217;re used for tons of official documents, and they&#8217;re stubbornly resistant to editing. That&#8217;s by design, of course. But technology always finds a workaround. And if you&#8217;ve got a [&hellip;]</p>
		<h3><a href="https://boingboing.net/2020/01/08/easily-edit-pdf-files-with-the.html">READ THE REST</a></h3>

	</div>
		
	
		<div class="nextstory">
	
		<h2><a href="https://boingboing.net/2020/01/08/enjoy-instant-muscle-relief-an.html?utm_source=moreatbb&utm_medium=nextpost&utm_campaign=nextpostthumbnails" onclick="clickTrack(this.href, 'Next Post Button', 'Next Post Thumbnails');">Enjoy instant muscle relief anywhere with this portable deep tissue massager</a></h2>
				
		<a href="https://boingboing.net/2020/01/08/enjoy-instant-muscle-relief-an.html?utm_source=moreatbb&utm_medium=nextpost&utm_campaign=nextpostthumbnails" onclick="clickTrack(this.href, 'Next Post Button', 'Next Post Thumbnails');"><img width="600" height="450" src="https://i1.wp.com/media.boingboing.net/wp-content/uploads/2020/01/product_34699_product_shots1.jpg?fit=600%2C450&amp;ssl=1" class="attachment-medium size-medium wp-post-image" alt="" srcset="https://i1.wp.com/media.boingboing.net/wp-content/uploads/2020/01/product_34699_product_shots1.jpg?w=630&amp;ssl=1 630w, https://i1.wp.com/media.boingboing.net/wp-content/uploads/2020/01/product_34699_product_shots1.jpg?resize=600%2C450&amp;ssl=1 600w, https://i1.wp.com/media.boingboing.net/wp-content/uploads/2020/01/product_34699_product_shots1.jpg?resize=300%2C225&amp;ssl=1 300w" sizes="(max-width: 600px) 100vw, 600px" /></a>
		
		<p><p>When real athletes train, they clearly don&#8217;t go into it blindly. Balance is important, and the recovery is just as important as the workout itself. As for the rest of us, we barely have time for the workout, much less a professional massage afterward. That&#8217;s why a professional-grade hand-held massage gun like the DEEP4s might [&hellip;]</p>
		<h3><a href="https://boingboing.net/2020/01/08/enjoy-instant-muscle-relief-an.html">READ THE REST</a></h3>

	</div>
		
	
		<div class="nextstory">
	
		<h2><a href="https://boingboing.net/2020/01/07/become-an-in-demand-digital-ma.html?utm_source=moreatbb&utm_medium=nextpost&utm_campaign=nextpostthumbnails" onclick="clickTrack(this.href, 'Next Post Button', 'Next Post Thumbnails');">Become an in-demand digital marketer in 2020 with the help of this training</a></h2>
				
		<a href="https://boingboing.net/2020/01/07/become-an-in-demand-digital-ma.html?utm_source=moreatbb&utm_medium=nextpost&utm_campaign=nextpostthumbnails" onclick="clickTrack(this.href, 'Next Post Button', 'Next Post Thumbnails');"><img width="600" height="450" src="https://i1.wp.com/media.boingboing.net/wp-content/uploads/2019/12/product_34520_product_shots1.jpg?fit=600%2C450&amp;ssl=1" class="attachment-medium size-medium wp-post-image" alt="" srcset="https://i1.wp.com/media.boingboing.net/wp-content/uploads/2019/12/product_34520_product_shots1.jpg?w=630&amp;ssl=1 630w, https://i1.wp.com/media.boingboing.net/wp-content/uploads/2019/12/product_34520_product_shots1.jpg?resize=600%2C450&amp;ssl=1 600w, https://i1.wp.com/media.boingboing.net/wp-content/uploads/2019/12/product_34520_product_shots1.jpg?resize=300%2C225&amp;ssl=1 300w" sizes="(max-width: 600px) 100vw, 600px" /></a>
		
		<p><p>Digital marketing in the coming decade will be a battle fought on multiple fronts. Companies are finding their customers on more web outlets than ever, and they&#8217;re not getting any less fickle. It can all be pretty confusing for anyone looking to make their brand breakthrough, but the 2020 Full Stack Digital Marketing Certification Bundle [&hellip;]</p>
		<h3><a href="https://boingboing.net/2020/01/07/become-an-in-demand-digital-ma.html">READ THE REST</a></h3>

	</div>
		

<!--googleon: all-->

	<!-- /5611/boinboing -->
	<div class="adslot notinuse" id="slot_not_in_use_1"></div>

</div>



  </div>
	<div class="adslot gumgum1x" id="boingboing_1x1_gumgum-inimage">
		<script data-cfasync="false" type="text/javascript">
			freestar.queue.push(function () { googletag.display('boingboing_1x1_gumgum-inimage'); });
		</script>
	</div>

<div id=”pmAdTag”><!-- Positive Mobile ad --></div>

<p>

<div id="footer" class="clearfix">

    <div id="footer-left">
        <p>Read the rules you agree to by using this website in our <a href="https://boingboing.net/tos">Terms of Service</a>.</p>
				<p>We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.</p>
				<p>Boing Boing uses cookies and analytics trackers, and is supported by advertising, merchandise sales and affiliate links. Read about what we do with the data we gather in our <a href="https://boingboing.net/privacy">Privacy Policy</a>.</p>
				<p>Who will be eaten first? Our forum rules are detailed in the <a href="https://bbs.boingboing.net/faq">Community Guidelines</a>.</p>
				<p>Boing Boing is published under <a href="https://creativecommons.org/licenses/by-nc-sa/3.0/deed.en_US">a Creative Commons license</a> except where otherwise noted.</p>
    </div>

    <div id="footer-middle">
    </div>

     <div id="footer-right">
      <p>		<a href="https://twitter.com/frauenfelder">Mark Frauenfelder</a>
     	<br>	<a href="https://twitter.com/doctorow">Cory Doctorow</a>
     	<br>	<a href="https://twitter.com/pesco">David Pescovitz</a>
     	<br>	<a href="https://twitter.com/xeni">Xeni Jardin</a>
     	<br>	<a href="https://twitter.com/beschizza">Rob Beschizza</a>
     	<br>	<a href="https://twitter.com/carla_sinclair">Carla Sinclair</a><br><span class="job">Editors</span></p>

     	<p class="staff"><a href="https://twitter.com/jlw">Jason Weisberger</a><br><span class="job">Publisher</span></p>
     	<p class="staff"><a href="https://twitter.com/orenwolf">Ken Snider</a><br><span class="job">Sysadmin</span></p>

   		<p>		<a href="https://boingboing.net/about">About Us</a>
			<br>	<a href="https://boingboing.net/contact">Contact Us</a>
			<br>	<a href="https://boingboing.net/advertise">Advertise</a>
			<br>	<a href="https://bbs.boingboing.net">Forums</a>
			<br>	<a href="https://store.boingboing.net">Shop</a>
			<br>	<a href="https://freestar.com/bad-ads/">Report a Bad Ad</a>
			<br>	<a href="https://bit.ly/boingboingdealssupport">Shop Support</a></p>
     </div>
</div>

<script type='text/javascript' src='https://c0.wp.com/c/5.3.2/wp-includes/js/comment-reply.min.js'></script>
<script type='text/javascript' src='https://c0.wp.com/c/5.3.2/wp-includes/js/wp-embed.min.js'></script>
<script type='text/javascript' src='https://c0.wp.com/c/5.3.2/wp-includes/js/jquery/jquery.js'></script>
<script type='text/javascript' src='https://c0.wp.com/c/5.3.2/wp-includes/js/jquery/jquery-migrate.min.js'></script>
<link rel='stylesheet' id='wp-block-library-css'  href='https://c0.wp.com/c/5.3.2/wp-includes/css/dist/block-library/style.min.css' type='text/css' media='all' />
<link rel='stylesheet' id='contact-form-7-css'  href='https://media.boingboing.net/wp-content/plugins/contact-form-7/includes/css/styles.css?ver=5.1.6' type='text/css' media='all' />
<link rel='stylesheet' id='aalb_basics_css-css'  href='https://media.boingboing.net/wp-content/plugins/amazon-associates-link-builder/css/aalb_basics.css?ver=1.9.3' type='text/css' media='all' />
<script type='text/javascript' src='https://c0.wp.com/p/jetpack/8.0/_inc/build/photon/photon.min.js'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var wpcf7 = {"apiSettings":{"root":"https:\/\/boingboing.net\/wp-json\/contact-form-7\/v1","namespace":"contact-form-7\/v1"}};
/* ]]> */
</script>
<script type='text/javascript' src='https://media.boingboing.net/wp-content/plugins/contact-form-7/includes/js/scripts.js?ver=5.1.6'></script>
<script type='text/javascript' src='https://s0.wp.com/wp-content/js/devicepx-jetpack.js?ver=202002'></script>
<script type='text/javascript' src='https://www.google.com/recaptcha/api.js?render=6LfQ94EUAAAAAE_uAfWqoJRPw1aQFzqdWFsfFTBO&#038;ver=3.0'></script>
<script type="text/javascript">
( function( grecaptcha, sitekey, actions ) {

	var wpcf7recaptcha = {

		execute: function( action ) {
			grecaptcha.execute(
				sitekey,
				{ action: action }
			).then( function( token ) {
				var forms = document.getElementsByTagName( 'form' );

				for ( var i = 0; i < forms.length; i++ ) {
					var fields = forms[ i ].getElementsByTagName( 'input' );

					for ( var j = 0; j < fields.length; j++ ) {
						var field = fields[ j ];

						if ( 'g-recaptcha-response' === field.getAttribute( 'name' ) ) {
							field.setAttribute( 'value', token );
							break;
						}
					}
				}
			} );
		},

		executeOnHomepage: function() {
			wpcf7recaptcha.execute( actions[ 'homepage' ] );
		},

		executeOnContactform: function() {
			wpcf7recaptcha.execute( actions[ 'contactform' ] );
		},

	};

	grecaptcha.ready(
		wpcf7recaptcha.executeOnHomepage
	);

	document.addEventListener( 'change',
		wpcf7recaptcha.executeOnContactform, false
	);

	document.addEventListener( 'wpcf7submit',
		wpcf7recaptcha.executeOnHomepage, false
	);

} )(
	grecaptcha,
	'6LfQ94EUAAAAAE_uAfWqoJRPw1aQFzqdWFsfFTBO',
	{"homepage":"homepage","contactform":"contactform"}
);
</script>
<script type='text/javascript' src='https://stats.wp.com/e-202002.js' async='async' defer='defer'></script>
<script type='text/javascript'>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:8.0',blog:'87954168',post:'761695',tz:'-8',srv:'boingboing.net'} ]);
	_stq.push([ 'clickTrackerInit', '87954168', '761695' ]);
</script>
<script>jQuery(function(){jQuery('#sidebar').height(jQuery('#features').height())});</script>

<!-- Analytics-->

<!-- Quantcast Tag -->
<script type="text/javascript">
var _qevents = _qevents || [];

(function() {
var elem = document.createElement('script');
elem.src = (document.location.protocol == "https:" ? "https://secure" : "http://edge") + ".quantserve.com/quant.js";
elem.async = true;
elem.type = "text/javascript";
var scpt = document.getElementsByTagName('script')[0];
scpt.parentNode.insertBefore(elem, scpt);
})();

_qevents.push({
qacct:"p-QX6JKE-6M4Jf7"
});
</script>

<noscript>
<div style="display:none;">
<img src="//pixel.quantserve.com/pixel/p-QX6JKE-6M4Jf7.gif" border="0" height="1" width="1" alt="Quantcast"/>
</div>
</noscript>
<!-- End Quantcast tag -->


<!-- Google Analytics include -->
<script>
function clickTrack(url, action, label){
    if(url && action && label){
        clickedURL = url;
        if(typeof(event) != "undefined") event.returnValue = false;
        ga('send', 'event', {
            'eventCategory' : 'UI Click',
            'eventAction'   : action,
            'eventLabel'    : label,
            'hitCallback'   : function () {
                document.location = clickedURL;
            }
        });
        return false;
    }
    return true;
}
</script>

<script>
  (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
  (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
  m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
  })(window,document,'script','//www.google-analytics.com/analytics.js','ga');

  ga('create', 'UA-3839311-1', 'auto');

      ga('set', 'dimension1', 'Cory Doctorow');
    ga('send', 'event', 'Permalink View', 'Author', '');

                ga('send', 'event', 'Permalink View', 'Category', 'Post');
                ga('set', 'dimension2', 'post ');
      
                ga('send', 'event', 'Permalink View', 'Tag', 'browser wars');
                      ga('send', 'event', 'Permalink View', 'Tag', 'competition');
                      ga('send', 'event', 'Permalink View', 'Tag', 'Copyfight');
                      ga('send', 'event', 'Permalink View', 'Tag', 'drm');
                      ga('send', 'event', 'Permalink View', 'Tag', 'eme');
                      ga('send', 'event', 'Permalink View', 'Tag', 'late stage capitalism');
                      ga('send', 'event', 'Permalink View', 'Tag', 'monopolism');
                      ga('send', 'event', 'Permalink View', 'Tag', 'perpetual internet domination licenses');
                      ga('send', 'event', 'Permalink View', 'Tag', 'standards');
                      ga('send', 'event', 'Permalink View', 'Tag', 'W3C');
                ga('set', 'dimension3', 'browser-wars competition copyfight drm eme late-stage-capitalism monopolism perpetual-internet-domination-licenses standards w3c ');
      
  
  ga('send', 'pageview');

</script>
<!-- end Google Analytics include -->

<!-- Begin comScore Tag -->
<script>
  var _comscore = _comscore || [];
  _comscore.push({ c1: "2", c2: "7518287" });
  (function() {
    var s = document.createElement("script"), el = document.getElementsByTagName("script")[0]; s.async = true;
    s.src = (document.location.protocol == "https:" ? "https://sb" : "http://b") + ".scorecardresearch.com/beacon.js";
    el.parentNode.insertBefore(s, el);
  })();
</script>
<noscript><img src="https://sb.scorecardresearch.com/p?c1=2&c2=7518287&cv=2.0&cj=1" /></noscript>
<!-- End comScore Tag -->

<script>
		function showmenu() {
			var currentHeight = document.getElementById("menuitems").style.height;
			if (currentHeight == "250px") {
				document.getElementById("menuitems").style.height = "0px";
			} else {
				document.getElementById("menuitems").style.height = "250px";
			}
		}
</script>
<script src="https://tags.crwdcntrl.net/c/8753/cc_af.js"></script>

<script>
    function createCookie(name,value,days) {
    var expires;
    if (days) {
        var date = new Date();
        date.setTime(date.getTime()+(days*24*60*60*1000));
        expires = "; expires="+date.toGMTString();
    }
    else {
        expires = "";
    }
    document.cookie = name+"="+value+expires+"; path=/";
}

function readCookie(name) {
    var nameEQ = name + "=";
    var ca = document.cookie.split(';');
    for(var i=0;i < ca.length;i++) {
        var c = ca[i];
        while (c.charAt(0)==' ') c = c.substring(1,c.length);
        if (c.indexOf(nameEQ) == 0) return c.substring(nameEQ.length,c.length);
    }
    return null;
}

var BNGEnqueueMC = readCookie('BNGEnqueueMC');

if( 'yes' === BNGEnqueueMC ) {
    // Embed scripts
    var mc1 = document.createElement("script"), el = document.getElementsByTagName("script")[0];
    mc1.src = '//downloads.mailchimp.com/js/signup-forms/popup/embed.js';
    mc1.setAttribute('data-dojo-config', 'usePlainJson: true, isDebug: false');
    el.parentNode.insertBefore(mc1, el);
    var mcInterval = setInterval(function(){
        if( 'function' === typeof PopupSignupForm) {
          require(["mojo/signup-forms/Loader"], function(L) { L.start({"baseUrl":"mc.us2.list-manage.com","uuid":"0e91f8e7df61da4bff2bd9b1f","lid":"8c5d27370d"}) });
          clearInterval(mcInterval);
        }
    }, 250);
} else {
    createCookie('BNGEnqueueMC', 'yes', 30);
}
</script>

</body>
</html>

